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What’s your ESRI software experience?
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Who We Are
Do you want to...

...Get a basic 
overview of GIS?

...Become more familiar 
with the ArcGIS Pro interface - 

add data, make a map, etc?
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Who We Are
Do you want to...

...Learn how to transition
my projects from

ArcMap to ArcGIS Pro?

...Learn how ArcGIS Pro 
integrates with ArcGIS Online?
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10%



ArcGIS Pro Interface

Making a Map

Migrating from ArcMap

Using Field Collected Data
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Getting Started



Q. Sounds like ArcMap is
going away and we will
need to learn ArcGIS Pro
moving forward. We’re
currently using ArcMap
in our office on a daily
basis.

Yes! ArcMap is in Mature support as of
this month (March 2024) and will be
fully retired in March of 2026.



Q: How do I get started
transitioning from
ArcMap to ArcPro? It’s
time for us to rip off the
band-aid and make the
switch at our office.

Take a free MOOC on a topic of
interest 

Make yourself do simple 
tasks in ArcGIS Pro

Give yourself an amount of
time to spend using Pro each
day (like an hour)

Make yourself use only 
ArcGIS Pro one day a week

Cartography class starting 4/3

https://www.esri.com/training/mooc/


Q: Computer
requirements for
handling the GIS
environment at
workable pace?

ESRI’s specs

minimum specs should perform fine for all but 3D

2-10 core CPU
8-64GB RAM

4GB graphics memory
DirectX11 or 12

1080p screen res
x64 platform

what I have:                                                          
Intel Core i7-10700 CPU @ 2.90 GHz - 8 cores
32 GB RAM
Intel UHD Graphics 630

https://pro.arcgis.com/en/pro-app/latest/get-started/arcgis-pro-system-requirements.htm#GUID-70D8DACC-78A9-4C57-A986-DFE62A9145E9


Create 2D and 3D Maps
Perform spatial analysis
Integrate and manage data
Access, publish and share
maps with your organization
and online
Edit data
Automate workflows
Create high quality maps for
print
Analyze imagery
Network analysis
3D modeling

What can you do
with ArcGIS
Pro?



MUCH better cartography and graphic
options

Fully integrated with ArcGIS Online - you
will be surprised how much you like and
use ArcGIS Online!

Tables are easier once you get the hang
of them - you can delete multiple fields,
rename fields, etc.

Multiple layouts and maps are great

Substantially faster

Q: What are your
perceived
improvements over
ArcMap?



It’s a BIG change.  Some things are the same, but
in general, the interface is very different.  Tools
are in all different spots and are context sensitive.
We are only going to scratch the surface today -
take advantage of classes in the ESRI Academy.

Allow yourself more time than you think you will
need.

Also, don’t try to transition every project over from
ArcMap - in many cases, it’s faster just to start
from scratch with a new project. You can still use
all the data you created in ArcMap in ArcGIS Pro,
so you’re not losing data, just project setups and
layouts.

Q: What is a lesson you
learned the hard way
or something that was
a big hurdle to cross
when you were first
getting set up with
ArcPro?



Interface



Projects in
ArcGIS Pro

Project has an *.aprx extension
It contains all maps, scenes, layouts (NOT data)
Connects to a default geodatabase  - it will create
a new one
Creates a new folder



ArcGIS Pro
Interface
Overview

Ribbon Map View

Contents 
Pane

Table
View

Catalog
Pane

Tabs6



Key Components of the Interface: Tabs

Starting Tabs include:
Project, Map, Insert,
Analysis, View, Share, Help.

Additional tabs appear
depending on what you‘re
doing.

Clicking on a tab changes the
tools.  Similar to MS Office
and other Windows
programs



Key Components of the Interface: Ribbon

Ribbon displays tools
based on which tab is
selected and also the
state of the
application. More
context sensitive
than ArcMap. Can be
customized.



Key Components of the Interface: Views

Map view

Table view

Scene view



Key Components of the Interface: Panes

Contents Pane
displays items
related to the active
view, which can be a
map, scene or
layout

Catalog Pane
Similar to

ArcCatalog



Toolbars are replaced by ribbons.
Ribbons and tabs are context sensitive.

Views and Panes are dockable and you
can move them around.

You can have multiple views and maps
in one project.

Q: What are the
major changes
between ArcMap
and ArcGIS Pro in
regards to where
tools and
operations are
located?



Q. Please show
tricks for
accessibility

In Options > User Interface: display keyboard shortcuts, scale interface
In Options > Application: Choose Light or Dark theme
View>Accessibility for Color Vision Simulator
Accessibility for layouts - add alt text - Element Pane
Keyboard Shortcuts

https://pro.arcgis.com/en/pro-app/latest/get-started/arcgis-pro-keyboard-shortcuts.htm


DEMO



Finding and 
Adding Data



Adding Data: from the Add Data tool 

On ribbon for Map Tab,
click “Add Data”

You can add data from a
variety of sources
including local drives,
server, your/your
organization’s online
portal content, the
Living Atlas, and all of
ArcGIS Online



Drag data from
“Databases” or “Folders”
tabs to the Contents
pane. 

Can also drag contents
from Portal (ArcGIS
Online), Computer, or
Favorites tabs.

Adding Data: from the Catalog Pane 



Saving Data Locations in the Catalog Pane

In Catalog Pane, Connect to
folders or geodatabases
where your data is stored in
the project or for all projects 

adding a folder as a
Favorite in ArcCatalog will
make it available for all
projects
adding a folder
connection in “Folders” in
ArcCatalog Project pane
will make it available in
that project



Finding Data

Q: ArcGIS Pro
tutorials skip the
basics like
finding the right
datasets and
moving them into
your project. How
do I do that?

In addition to any
local data you or
your organization
might have, there
is a wonderland of
data available
through the Living
Atlas and ArcGIS
Online.



Adding Data: 
From the Living Atlas and ArcGIS Online 

the Living Atlas is a curated collection of authoritative data from ESRI, ESRI partners
and trusted agencies.  It is a subset of ArcGIS Online.  Some of it requires a subscription
but much is free to to use for anyone with an ArcGIS Pro license. You can be confident
that Living Atlas data is vetted by experts in the subject matter.

ArcGIS Online is ESRI’s cloud-based platform for hosted GIS data.  This data can be
made available by anyone.  There is some good data, but you should be more cautious
when using this data.



Adding Data: 
From the Living Atlas and ArcGIS Online 

Click on “Add Data” button from Map tab. Click on Living Atlas on left hand side and
then search by topic in upper right corner.

5. Click OK to add to map

1.Click on
Living Atlas

2. Search here
3. Click to
select data
you want 4. View

Metadata



Elevation Data

Q: How do I use
lidar or 2ft
contours?

In addition to the data available through ArcGIS Online and the Living Atlas,
the New York State GIS Clearinghouse has curated data for download from
federal, state and local agencies, as well as access to hosted data layers
and apps through an ArcGIS Online Hub site.

2' contours and lidar data can be downloaded through the Clearinghouse.

https://data.gis.ny.gov

https://data.gis.ny.gov/


Soils Data

Q: In ArcMap
there is a soil
data viewer. Will
there be a NEW
soil data viewer in
ArcGIS Pro?
Because as of now
there is NOT one.

There is not currently a soil data viewer for
ArcGIS Pro.  One may be coming later this
year?

In the meantime, SSURGO soils are available
for use in ArcGIS Pro through the Living Atlas.



DEMO



Creating New Data



Q: How can I be
efficient with
data? When do I
use a
geodatabase?

For the most part, unless you’ll be
sharing data with someone who

doesn’t have ESRI software, using
a geodatabase is the best bet.

The MOST efficient way to use data is from ArcGIS Online. If you
are not the authoritative source for the data and a web layer is
available in ArcGIS online, use it. 

If using local data, only make copies when absolutely necessary
for editing. 

If other people will be using the data or you will be using the data
for other projects, create the geodatabase in a shared location.

If you’re creating data just for a particular project that will not be
shared (or you will share the whole project), store it in the project
geodatabase.



What is a Geodatabase?

Collection of geographic datasets of
various types:

Tables 
Feature classes
Raster datasets

Unlike shapefiles, can contain
multiple layers of information



Creating a New Geodatabase

In Catalog Pane, right click on
Databases and choose “New File
Geodatabase”

Note that a new Geodatabase is
automatically created when you
start a new project, so you don’t
need to create another one, unless
you have a reason to (you’re
creating a “master” geodatabase,
shared geodatabase, etc).



1. In Catalog Pane, right click
on geodatabase in Databases
where you want to create
new layer and choose “New”

Creating Feature Classes 
in a Geodatabase

2. Click arrow next to New
and choose Feature Class 



Click Next

3. Enter Layer Name 
and select type of
data

Creating Feature Classes 
in a Geodatabase

Click Next

4. Enter Field Names
and Types

Click Next

5. Select Coordinate
System

6. You can take the defaults for
the next three screens (Tolerance,
Resolution and Storage) and then
click Finish.



Editing a New Feature Class

Big Change!
No more stopping and starting the Editor. You do not
need to start an edit session in ArcGIS Pro - just go to

the edit tab. You will be editing whichever layer is
selected in the Contents pane.



1 New Feature Class is added to
the current Map pane (or you can
drag it over from Catalog)

Editing a New Feature Class

2. Click on the Edit tab

3. Click on the Create tool

4. If desired, dock
the Create
Features pane

5. Click on the new
layer in the Create
Features pane to
activate it and then
click on the map to
create a new feature



1 In the Edit Tab, click on
Attributes

2. If desired, dock
the Attributes
pane

3. Make sure the new feature is
selected on the map. Enter the
attributes and then click Apply.

Adding Attributes
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How to Make a Map



Similar to ArcMap, but way more options - click on
layer name in Contents Pane. Click on Feature layer
tab at top for Transparency/Blend Options

Symbology Overview

Right click on layer in Contents pane and
choose Symbology for more options



 In Symbology Pane, dropdown to choose
desired Symbology type

Symbology Overview

Right click  on values to delete,
group, change text for label, reorder

or select different symbols

If using Unique Values, 
select desired Field



Right click on layer you want to label
and choose Labeling Properties. 

Labeling Overview

There are TONS of options for labeling -
way more than ArcMap. Default labeling
engine is Maplex.
There is a labeling ribbon with multiple
tools as well as a labeling pane.
You can label layers with expressions -
default language is Arcade.
Same as ArcMap, you can’t move the
labels - they’re dynamic.



Labeling Overview

Click on Class tab for choosing label field or creating label expressions. 

This link has lots of helpful examples of expressions.

The Symbol tab allows
setting of font, size, color,
halo, shadow, position, and
background symbol

The Position tab has TONS
of positioning options,
including special placement
for parcels, waterbodies,
stacking, etc. 



Q: Can you go over
some of the
autolabeling
options for
polygons? I always
end up converting
all the labels to
graphics which
takes forever

Me too!

Tip: If you are making a map for print, create your layout and
figure out the scale for the map on the layout.  Then set the
scale in the Map view to be the same (lower left hand corner).
You can also set this as the reference scale for the map (right
click on the map in the Contents Pane and choose Reference
Scale). THEN go into labeling properties and set up labels.

ANOTHER OPTION for converting to graphics: convert to
annotation instead.  You’ll get lots of control over placement
and then you can reuse the labels in other maps and projects.



2. Layout Tools are
on both the Layout
and Insert tabs. Click
on the Insert tab and
select the Map Frame
tool. Then select the
map you want to
insert on the layout
and then draw the
frame on the map to
add it to the layout.

1. In the Insert Tab, click on New
Layout and choose Size and
Orientation.This will create a
new blank layout.

Creating Layouts



3. All of the traditional Layout tools (north arrow,
scale bar, legend, graphic text etc) are on the
Insert tab. Click on a tool to activate and then
draw a box for the location for the item on the
layout.

Creating Layouts



4. Each of the elements (map frame, legend,
scale bar, north arrow, graphic text, etc) can be
edited in the Elements pane.
On the Layout tab, click the Select tool and
then select the element on the layout you
would like to edit.

Creating Layouts
5. Right click on the selected element
and choose Properties.  This will open
the Elements Pane where you can edit
parameters.  



6. To print or export (to .pdf, etc) a layout, click on the Share tab.

Creating Layouts



Q: In the layout
section, is there
an easier way to
move the map
other than zooming
to the selection?

Yes! This is a major difference with
ArcMap.

Instead of the “Map
Toolbar” in ArcMap, in
ArcGIS Pro you need
to select the data
frame in the layout,
right click and choose
“Activate”. Then you
can interact fully with
the map (more than
you can in ArcMap).
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Working with Tables



Tables can refer to attribute tables for feature
classes, or standalone tables.

Supported types of tables: geodatabase, database,
feature layer attribute table, dbase (.dbf), excel, text,
ASCII, csv 

In ArcGIS Pro, you work with tables in Views. Like
other Views and Panes, you can move them around
and dock them and stack them however you’d like.

ArcGIS Pro has much more flexibility for editing
tables than ArcMap - it’s much easier to add, delete
and rename fields.

Table Basics



Working with Tables

1. Open an attribute table for
a layer by right clicking on it
and choosing Attribute Table

2. If desired, dock/move the
table. Once a table is
opened, a Table tab is added.
This is where the majority of
the Table tools are located.



Working with Tables

3. Most of the tools are
similar to ArcMap (Joins,
Relates, Select by Attributes,
display of selected records,
etc). Multiple layers can be
tabbed across the top. 
Right click on a tab for 
table arrangement 
options.

4. Right click on a field for
field options (calculate 
field, calculate geometry,
sort, statistics, etc).



5. Very different: managing
fields.  

Multiple fields
can be deleted at
once by selecting 
them and clicking
the Delete tool.

Click on the Add tool
to add multiple fields
at once and/or rename
fields.

Working with Tables

Click on the Add tool
to add multiple fields

at once and/or rename
fields. Double click on

a field name to rename
it.  Click in an empty

row at the bottom to
add fields. Click Save

tool when finished.



There is more flexibility with
importing tables in ArcGIS Pro
than there is in ArcMap. Excel
files can come in in native format,
which is great! However, tables
need an ObjectID field to be used
fully, so standalone Excel tables
should be converted to .dbf or
brought into a geodatabase. Use
Excel to Table tool.

Tables (Excel or .csv) that have
XY data can be converted to
point feature classes using the
XY Table to Point tool. 

Q: Please talk
about excel and
.csv point data
sets
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Migrating from
ArcMap



Q. As I use Pro I find
many tools and
interfaces that I found
to be quite handy in
ArcMap are either no
longer an option or I
cannot find them to use,
or they are buried in
layers that don’t
necessarily align with
their location/uses in
ArcMap. 

Take advantage of Customize and the Quick
Access toolbar. Put your favorite tools in easy to
locate spots.
Take time to go through all the tabs and
dropdown menus. 
Use the Search boxes - there are tons of them.
Use right click menus - lots of tools are located in
them.
Hover! Every tool tells you what it does.

One of the biggest pain points of transitioning is
that the tools are in all different spots or “buried”.
Here are some tips for helping to get over that
hurdle:



In ArcMap, as in ArcGIS Pro, the data is stored separately from the project file.  
The project file contains tools, maps, layouts, symbology, labeling, and
POINTERS to the data, but not the actual data itself.

There are three common types of data used in ArcMap: shapefiles, personal
geodatabases, and file geodatabases.  Shapefiles and file geodatabases can be
opened directly in ArcGIS Pro (some file geodatabase features will need to be
upgraded).  Most raster data will come in with no issue, but raster catalogs need
to be migrated to mosaic datasets. (There is a simple tool to do this).

Personal geodatabases are not supported by ArcGIS Pro and will need to be
converted either in ArcCatalog or by using a sample conversion tool in ArcGIS
Pro, which can be downloaded here.

Transitioning Data

https://www.arcgis.com/home/item.html?id=b2649c0161054fe186c54b567c7cb196


Maps and Layouts can be imported using a tool in ArcGIS Pro.

Transitioning Projects

1. Click on the Insert tab 2. Click on the Import Map tool 3. Navigate to and select
the .mxd file you want to
import. Click Ok.



4. A new map with the same name as
the data frame in your project will be
added to ArcGIS Pro.  If there was a
layout in the project, it will be added as
well.  If there was more than one data
frame in your ArcMap project, each one
will be added as a new map.

REMEMBER that ArcGIS Pro can have
more than one layout and map, so you
can import multiple .mxds into a single
ArcGIS Pro project.

Transitioning Projects



Also REMEMBER: 
the data does NOT get imported into the new project

geodatabase - it’s still in the same spot it was previously 

Transitioning Projects



Q.
Will we still be
able to use files
from ArcMap
after NRCS shuts
down the
program?

Yes. Remember data  is separate
from projects, so it can still be
accessed (aside from personal
geodatabases). 

ArcMap Projects (*.mxds) can be
used after importing to ArcGIS Pro.

Custom tools will be lost if they have
not been redeveloped for Pro.



Using Field 
Collected Data



Q. How can I
import GPS
survey data into
ArcGIS Pro? How
do I work with it?

For “old school” GPS data (not collected
using Field Maps or Survey123):

Export data out of your GPS unit
into .gpx format (this is the
standard GPS interchange format).

1.

In ArcGIS Pro, click on the Analysis
tab and then click on Tools

2.

In the search bar, type “gpx to
features”

3.

Click on the GPX to Features tool.
Select your GPX file and specify
the output location (it can go in
your project geodatabase).

4.

Work with it like you would any
other layer. 

5.



Data collected via the Field Maps or Survey123 apps is stored in a feature dataset in
ArcGIS Online.  It can be accessed via the “Add Data” button on the Map tab or via the
Catalog Pane. Search in “My Organization” under Portal to find field data collected by
someone in your office.

Search for it by name 
and add it to a map.

Remember it is live data! If it is still 
being used for data collection and 
you want to edit the data, 
make a copy of it.

Using Field Data from Field Maps or Survey123
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Questions and
Answers



Resources for Additional Questions
How to Mosaic a DEM

How to Delineate a Watershed

How to Calculate the Volume of a Basin

How to make a pivot table

ESRI Academy - lots of good free classes!

https://pro.arcgis.com/en/pro-app/3.1/help/data/imagery/creating-mosaic-datasets-wf.htm
https://www.youtube.com/watch?v=4Am8yHPSmhw
https://pro.arcgis.com/en/pro-app/3.1/help/data/imagery/measure-feature-volume-based-on-an-elevation-surface-raster.htm#ESRI_SECTION1_C30D73392D964D51A8B606128A8A6E8F
https://www.youtube.com/watch?v=1lmzUhoIu9g
https://www.esri.com/training/


Questions?




